首页>软件资讯>常见问题

常见问题

Aspen低版本软件如何打开高版本文件?

发布时间:2023-03-20 14:07:15人气:973

正常而言,我们的Aspen Plus是无法正常实现低版本打开高版本的(或者打开时会提示警告)。其原因是这样的,因为Aspen的数据库是每一个版本更新一次的,低版本的软件中没有高版本的数据库备份,但是高版本的软件中有低版本数据库的备份。所以,我们的高版本可以打开低版本,但低版本打不开高版本。那么,如果我们真的遇到这种需要用低版本打开高版本的情况,我们可以通过什么操作完成呢?

以Aspen V11打开Aspen V12的文件进行示例,可以打开文件,但是会提示两个问题,首先是版本问题,我们点击确定后,软件还是可以打开文件的,但是又会提示数据库缺失的问题。这是很正常的,因为文件当中提供的数据库信息低版本里面没有,当然就显示数据库缺失了。

1.png

2.png

首先第一步,我们解决版本问题警告,这个问题就可以直接通过上面的方法完成。将.bkp文件后缀修改为.txt,打开txt文件我们会发现第一行描述其版本为38.0(这是Aspen V12的版本,和其PURE数据库版本数字是一致的,大家可以看数据库确定不同Aspen版本的版本数字),这就是第一个警告识别的位置。我们将其修改为37.0(这是Aspen V11版本)。

3.png

4.png

修改前


当然如果你往下看txt文件,还可以看到选择物性方法,软件调用的数据库,如上图所示,这些就是导致第二个问题提示警告的原因,但是如果改这里的话,要改的就太多了,所以这个咱们等待后续在软件中处理。

5.png

修改后-“将38.0改为37.0”

6.png

保存后将文件格式修改回“bkp”


修改完成保存后将.txt文件改回.bkp文件,然后用Aspen Plus软件打开。第一个警告在这里我们就看不到了,而只会显示第二个警告(但是第一个警告的问题事实上还没有解决,只是警告不提示了),文件也会显示输入不完整,因为数据库不对。这里提示的是数据库是APV120 PURE38 和APV120EOS-LIT缺失(可以看到修改了最开始的38确实没有解决数据库的问题,只是把警告消除了而已)。

7.png


第二步,我们需要在物性界面,找到组分输入界面的企业数据库,添加APV110 PURE37来代替APV120 PURE38。

8.png


其次,在二元交互参数界面,目前由于没有APV120EOS-LIT,所以本来调用出来的数据也都没有了。这里我们找到该界面的数据库窗口,用APV110EOS-LIT取代APV120EOS-LIT。

9.png

10.png

上述步骤,由于软件版本不一样,流程不一样,操作过程不一定全部都需要,选择的数据库也可能会不一样,大家照着自己的软件版本和窗口提示的数据库修改即可。如果直接能打开文件进行数据库的修改的话,第一步可以省略。


但是,需要注意的是,高版本修改成低版本后,因为我们人为使用了低版本数据库模拟,所以不能完全保证软件运行结果和高版本一致。尤其是遇到某些在高版本数据库当中有的数据,低版本数据库并没有,模拟结果就可能有较大的差异。


上一条:电脑抓包软件推荐_Fiddler

下一条:ChemDraw软件